Actualizar Sextante en gvSIG 1.11

Hola.

Dado que la versión 0.6 de Sextante que viene embebida en gvSIG 1.11 da problemas con algunos algoritmos, hemos empaquetado el último nightly build de Sextante (con fecha 19-10-2011) y lo hemos agregado al repositorio de paquetes de gvSIG 1.11 para que los usuarios puedan actualizarlo de manera relativamente sencilla desde el administrador de complementos de gvSIG.

Pese a que, según hemos podido comprobar, muchos de los errores de Sextante reportados por usuarios de gvSIG 1.11 ya no suceden con esta actualización, no debemos olvidar que se trata de una versión en desarrollo por lo que, tal y como se recomienda en la propia web de Sextante, es preferible no utilizarla en entornos de producción.

Debido a algunos problemas del propio administrador de complementos de gvSIG el proceso todavía no es completamente automático. A continuación se describen los pasos a realizar para actualizar Sextante en gvSIG 1.11.

1. Descargar el fichero de paquetes de gvSIG 1.11 desde la siguiente URL:

http://downloads.gvsig.org/download/gvsig-desktop/pool/es.unex.sextante/gvSIG-desktop-1.11.0-es.unex.sextante-0.6.0-20140410-testing-all-all-j1_5.gvspkg

Nota: en función del navegador utilizado es posible que en el proceso de descarga la extensión del fichero cambie a .zip. En tal caso será necesario renombrar el fichero para que vuelva a tener su extensión original (.gvspkg).

2. Borrar la carpeta “es.unex.sextante” ubicada dentro del directorio de instalación de gvSIG. Habitualmente:

  • En Linux: /home/[usuario]/gvSIG_1.11.0_final/bin/gvSIG/extensiones/es.unex.sextante/
  • En Windows: C:\Archivos de programa\gvSIG_1.11.0_final\bin\gvSIG\extensiones\es.unex.sextante
  • En MacOS: /Applications/gvSIG-1.11.0.app/Contents/Resources/Java/gvSIG/extensiones/es.unex.sextante

Nota: es conveniente hacer una copia previamente por si acaso algo va mal.

3. Arrancar gvSIG (en Windows arrancar en modo administrador).

4. Ir al administrador de complementos (menú Herramientas -> Administrador de complementos).

5. Seleccionar “Instalación desde fichero” e indicar la ruta hasta el fichero gvSIG-desktop-1.11.0-es.unex.sextante-0.6.0-20140410-testing-all-all-j1_5.gvspkg previamente descargado (punto 1). -> Siguiente.

6. En la pestaña “No oficial” seleccionar la última versión del paquete -> Siguiente (el proceso puede tardar algunos minutos).

7. Cerrar gvSIG.

8. SOLO PARA WINDOWS: Ir a la carpeta “extensiones\com.iver.cit.gvsig\lib” y borrar los ficheros:

  • jts-1.9_gvSIG.jar
  • jtsio-1.8.jar

9. Arrancar gvSIG.

Espero que os sea útil.

Saludos,

Manuel.

About Manuel

gvSIG Product and Testing Manager
This entry was posted in community, gvSIG Desktop, spanish, testing. Bookmark the permalink.

32 Responses to Actualizar Sextante en gvSIG 1.11

  1. paul dassori says:

    Hola Manuel
    He seguido todos los pasos y no logro actualizar Sextante, me lanza el siguiente mensaje “Error creando el archivo de salida”. Lo otro que encuentro raro, es que al eliminar la carpeta es.unex.sextante, y abrir el programa aún sigue activo el icono de Sextante y si lo activo aparece la ventana de menú, es como si no lo hubiera eliminado. Es normal??

    Sistema Operativo: Ubuntu 10.04
    gvSIG: versión 1.11.0

    Saludos desde el Sur de Chile.

  2. Luis says:

    Estimadisimo manuel, a mi me pasa lo mismo al quwerer realizar la faena, solamente que cuando elimino el archivo unex, ya no me aparece el icono en el menú. Gracias

  3. Manuel says:

    Hola Paul y Luis.

    El “error creando el fichero de salida” sucede cuando el usuario con el que has entrado en el sistema no tiene permisos de escritura en el directorio de instalación de gvSIG. ¿Es posible que el usuario con el que estáis intentando actualizar Sextante sea uno distinto al que utilizasteis cuando instalasteis gvSIG?

    Respecto al problema de que sigue saliendo los iconos de Sextante después de borrar la carpeta, Paul, ¿es posible que tengas más de una instalación de gvSIG y que la que estés ejecutando no sea la misma que en la que has borrado la carpeta?

    Aprovecho para recordaros (se me olvidó hacerlo en el entrada) que el lugar más adecuado para reportar problemas es la lista de usuarios [1]. De esa manera las soluciones a los problemas se reaprovechan al máximo.

    Gracias por vuestra colaboración.
    Saludos,
    Manuel.

    [1] http://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_usuarios

  4. Luca says:

    Ciao Manuel,
    ho fatto l’aggiornamento. Tutto ok. Un solo problema: non posso più configurare GRASS. Perché è scomparso il menù di configurazione della directory dove è installato GRASS.

    Grazie

    Luca

  5. Manuel says:

    Ciao Luca,

    Efectivamente en esta versión han desaparecido los controles para configurar GRASS. Esperemos que en futuras versiones sí que se pueda.

    Por si te sirve, te puedo decir que hemos hecho algunas pruebas y en el caso de Ubuntu, si GRASS está instalado en la ubicación estándar (en la que se instala cuando lo haces desde el repositorio oficial de Ubuntu) Sextante lo reconoce y carga los procesos en la tool box.

    De momento es todo lo que sabemos. Si descubrimos cómo hacerlo os lo comunicaremos.

    Saludos,
    Manuel.

  6. Luca says:

    Grazie Manuel. la mia macchina è Ubuntu 11.10 64 bit e ho installato GRASS da repository ma purtroppo sextante non trova i percorsi di installazione.
    Aspettiamo la prossima versione.

    Ciao

    Luca

  7. Pingback: Actualizar Sextante en gvSIG 1.11 « geoprocessamento.org

  8. cecilia says:

    ola lo que pasa q me piden q elabore un sextante con materiales reciclables y no se cuales ni como

  9. Ulises Martin says:

    Ufff, me funcionó de maravilla. Gracias.

  10. Flor Alvarez says:

    A mi también me sale lo de “error escribiendo tabla” y estoy con el usuario con permisos de administrador. ¿Alguna sugerencia?
    SO. Windows vista
    gvSIG 1.11.0

  11. anonim says:

    click derecho y “Ejecutar como administrador”

  12. oscar hernandez says:

    Hola manuel, necesito georeferencia una capa vectorial no una imagen, en una version de gvsig se podia por el gestor de geoprocesos, conversion de datos: ajuste espacial de capas, pero en versiones 10 y 11 no aparece este algoritmo, ayudame que necesito georeferencia una capa vectorial de manera urgente.

  13. Paco says:

    Hola Manuel:
    En un mac OS X 10.5.8, una vez sustituido el Sextante como indicas arriba, cada vez que intento abrirlo se cuelga. Y si no lo sustituyo, sencillamente ni funciona.
    Te agradecería mucho alguna solución

  14. Eve says:

    Hola por favor necesito ayuda. al momento de instalar gvsig aparece una ventana diciendo que el dirctorio ya existe y si deseo reemplazarlo… en fin no me instala=(

  15. Manuel says:

    Hola Eve.

    El lugar adecuado para solicitar soporte es la lista de correo de usuarios [1]. Te recomiendo que te registres y envíes un correo describiendo detalladamente el problema (pasos). También es importante que indiques lo siguiente:
    – Versión de gvSIG
    – Sistema operativo

    Saludos,
    Manuel.

    [1] http://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_usuarios

  16. maria says:

    está muy bien la explicación, pero hay que tener en cuenta que en el paso 3 hay que abrir el gvSIG como administrador, sino aparecerá un error creando el archivo de salida. Para ello, hacer click con el botón derecho en el icono, y abrir como administrador.
    saludos
    maria

  17. Sergio says:

    Hoy procedi ha cambiar el sextante por la versión recomendada en esta hoja, sin embargo me surgio una duda como se procede para instalar Grass ahora, disculpen la pregunta del sastre pero no soy expero sino únicamente un aprendiz.

  18. Sergio says:

    solo algo, me funciono el cambio

  19. estimado, instale linux, y gvsig con todas las extensiones, pero cuando trato de cargar sextante segun tus pasos, me sale un cartel, luego de seleccionar el archivo, que dice: error añadiendo el recurso, error reading the plugin invalid block type (java.util.zip.ZipException)

  20. Irene says:

    Hola Manuel,
    si borro los archivos jts-1.9_gvSIG.jar y jtsio-1.8.jar del último paso, el programa no me permite crear nuevas vistas (me indica que hay un error y que debo cerrar gvsig). ¿Es imprescindible que lo borremos?

    Muchas gracias!!
    Irene

  21. Manuel says:

    Hola Irene,

    Si la actualización se ha realizado correctamente deberías tener dos ficheros de cada (dos jts y dos jtsio). Si no es así, deberías volver a intentar la actualización. Comprueba que el usuario con el que estás ejecutando gvSIG sea el mismo que utilizaste para instalarlo o, en su defecto, ejecuta gvSIG en modo administrador. Es imprescindible que tengas permisos de escritura en el directorio de instalación de gvSIG.

    Suerte.
    Manuel.

    • Irene says:

      Solucionado Manuel! Muchas gracias!!

      Irene : )

    • iratxe says:

      Hola Manuel,
      He realizado la actualización del archivo como administrador y no me ha dado error. Sin embargo no me aparecen los dos ficheros de cada (dos jts y dos jtsio). He vielto a realizar la actualización y lo mismo. Me he desinstalado y vuelto a instalar el programa. Donde puede estar el fallo?

      Muchas gracias,
      Iratxe

      • Manuel says:

        Hola Iratxe.

        ¿Qué versión de los ficheros tienes? (Va en el nombre)

        Saludos,
        Manuel.

        • iratxe says:

          Hola Manuel,
          El nombre de los archivos es:
          jts-1.9_gvSIG
          jtsio-1.8
          Su ultima modificación fue el 1 de abril de 2011

          Muchas gracias

  22. enric says:

    Hola!
    uso ubuntu 12.04 64 bits y siguiendo los pasos, cuando ejecuto sextante me da “error no detectado por el usuario”.
    ¿Alguna idea?
    gràcies!
    enric

  23. Victor says:

    Muchas gracias por la ayuda. Funciona

  24. vic says:

    hol buenas tardes, tengo gvSIG 2.0 y al intentar usar el sextante para eliinar depresiones del analisis hidrologico basico, se queda pensando sin responder, que podria hacer en este caso?

  25. Alvaro says:

    Hola Vic,
    Te recomiendo que utilices gvSIG 2.1, que corrije los bugs detectados en gvSIG 2.0 y trae mucha funcionalidad nueva. De todos modos, para dudas y problemas técnicos lo mejor es que utilices la lista de usuarios de gvSIG, que puedes encontrar aquí: http://www.gvsig.org/web/community/mailing-lists

  26. silvia CASAS says:

    muchisimas gracias Manuel!!! Estaba totalmente atascada, y ahora funciona de maravilla el sextante, de momento……

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s